Great deals on JK parts on Amazon!

Looking for parts for your Jeep Wrangler JK? Checkout the selection of JK parts Amazon has to offer, many with 2-day Prime shipping!

Click the image below to browse JK parts on Amazon.

Jeep Wrangler JK Parts on Amazon

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.

Jeep will turn over starter, but not Run only after driving it


Dee2005

New Member
Joined
Dec 13, 2021
Messages
8
Location
Louisiana
I have a problem with my 2017 Jeep Wrangler 68k .. After driving it with in a short time being off it will turn over but not Run . If it sits for hour or two it will Run .
It will Run after sitting off for a long time - overnight , while at work all day. If it runs in park for 30 minutes are more it will Run , has to be moving for it to not run the next time its turned off . No check engine light
The Battery is good , replaced starter and Cam/Crank sensors, ck fuses box and wire connections to fuse box.
It wont Run in Neutral..
Any suggestions
 

BLACKJKU

Moderator
Staff Member
Lifetime Supporting Member
Joined
Feb 22, 2020
Messages
2,552
Location
Huntington In
Do any lights come on just before it quits running? Have you checked to see if there are any CEL's?
 
OP
D

Dee2005

New Member
Joined
Dec 13, 2021
Messages
8
Location
Louisiana
Do any lights come on just before it quits running? Have you checked to see if there are any CEL's?
When its running everything is fine no lights , but you turn off then try start shorty after and it tries to start but want run like it has no fuel .. Does not do it every time you drive just occasionally
 

BLACKJKU

Moderator
Staff Member
Lifetime Supporting Member
Joined
Feb 22, 2020
Messages
2,552
Location
Huntington In
When its running everything is fine no lights , but you turn off then try start shorty after and it tries to start but want run like it has no fuel .. Does not do it every time you drive just occasionally

I wonder if you could have gotten some bad gas with water in it, water will get trapped in the filter and restrict the fuel flow. The bad is I found out the filter is in the fuel tank on the module. Might try running some of the Heet in a yellow bottle to see if that would help.
 
OP
D

Dee2005

New Member
Joined
Dec 13, 2021
Messages
8
Location
Louisiana
I thought it may have to do with the Fuel , but this started about 2 months ago and once it runs every thing is fine .. I was thinking if it was the fuel or fuel system it would have issues while driving it.. Only when you try to start it
 

BLACKJKU

Moderator
Staff Member
Lifetime Supporting Member
Joined
Feb 22, 2020
Messages
2,552
Location
Huntington In
If it's been that long ago then probably not fuel related. Not sure if this will help or not but dirty grounds can cause problems and damp weather will cause problems with bad grounds.
 
  • Like
Reactions: BigAL07

Vman

JK Enthusiast
Joined
Aug 23, 2021
Messages
184
Location
Pacific NW
I thought it may have to do with the Fuel , but this started about 2 months ago and once it runs every thing is fine .. I was thinking if it was the fuel or fuel system it would have issues while driving it.. Only when you try to start it

Is it an automatic and does it do this?

 

Vman

JK Enthusiast
Joined
Aug 23, 2021
Messages
184
Location
Pacific NW
Will try next time it wont run thanks

Is that the sound it makes? If so, could be grounds as already mentioned, could be your selector cable needs adjusted, or it could be the neutral safety/range sensor in the transmission.

I don't know what the process is for the 5 speed, I have a 3.8 07-11 JK, but I did end up having to replace the range sensor in mine.
 

Vman

JK Enthusiast
Joined
Aug 23, 2021
Messages
184
Location
Pacific NW
No , the starter turns over dash lights come on , It like it is not getting fuel to run .

Take it back to basics and check for spark and fuel after it warms up. Sounds like you're only having problems when things get hot.

Could be anything from a bad fuel pump to a bad coil or other things.
 
  • Like
Reactions: BigAL07

BLACKJKU

Moderator
Staff Member
Lifetime Supporting Member
Joined
Feb 22, 2020
Messages
2,552
Location
Huntington In
Take it back to basics and check for spark and fuel after it warms up. Sounds like you're only having problems when things get hot.

Could be anything from a bad fuel pump to a bad coil or other things.

Yea I never thought about the coil heat can cause issues with them when they get weak.

Just buy a OEM coil if you do decide to try that.
 
  • Like
Reactions: Vman

JeepJeezy

Member
Joined
Jun 8, 2021
Messages
78
Location
717
I had the same thing happen to my WJ. I know, not the same Jeep, but my problem was the CPS. Never threw a code, never flashed a check engine light and never stored a code. The sensor had a slight crack and when it got hot the crack would open up and not let me start it again till it cooled down. I'm not sure where it's located on the JK but on a WJ it's right behind the starter. Had to pull the starter to get to the CPS. Ended up buying a new starter too. Don't ask 😒
 
OP
D

Dee2005

New Member
Joined
Dec 13, 2021
Messages
8
Location
Louisiana
I took it to the Dealer and they got it to not run and said the the totally integrated power module was not sending power to Fuel pump. Going replace the TIPM and see if this resolves the problem or it the Fuel pump is bad. ..
I did tell them what you found as well
Tks
 

xR3SEARCHx

New Member
Joined
Jan 10, 2022
Messages
7
Location
CCTX
Ive had multiple vehicles with that problem, of different makes, but after the first of going threw fuel system electrical ect..... And some research I found it was the crankshaft position sensor. Then on the second time it came up the vehicle (different from first) would while driving randomly shut off and not run again for 30 or so min. I found that one had a hairline crack that when heated up would expand and fail. On both times was a 60$ 2 screw fix, maybe what your battling.