Wiring problems with 99 TJ

Status
Not open for further replies.

Gene

New Member
Joined
Jun 25, 2020
Messages
1
Location
Fortville, IN
New to the forum. Hello all.

To keep this post reasonable short on September 27 my son totaled his 99 2.5 Wrangler TJ, he got T bone, I told him I would fix it it's his pride and joy. Nine months later here I am. New frame, new tub,paint, POR 15, Raptor Liner I could go on but the list is endless. I rebuilt the used 4.0 that is currently in it.

So here is my problem, wiring I am a Tool Maker wiring is not my thing. I can use a meter but that is the extent of it.
Anyway here is whats happening. No Bus no gas gauge reading fuel pump works. Running lights work, no headlights. No starter engagement when I turn the key.

I have check every ground that I KNOW of, firewall, behind the gauge cluster, right side kick panel, grounds near the front speakers, grounds located on the inside of the grill by the lights. I have checked every fuse and relay, I do have power to both fuse boxes. I have removed the gauge cluster and cleaned the terminals, removed the plugs from the dash and manually plugged them in.

I do have Two 02 sensors that are not plugged in, as of late last night I could not locate the wires. I have a couple of plugs under the dash drivers side right foot location that are not in use, I can't find anything that they plug into. I also have two on the passenger side firewall that are not in use here again I can't find anything for them.

Thanks in advance for your help.

Jeep.jpg
 

Chris

Administrator
Staff Member
Joined
Sep 28, 2015
Messages
31,207
Location
Florence, AZ
Do you know you're on the wrong forum? This is a forum for 2007-2018 Jeep Wrangler JKs. You have a TJ.

The forum you are looking for is this site's sister forum:


Register and post this there as you'll get way more help since it's a TJ specific forum.
 
Status
Not open for further replies.