Transmission stuck in park

Frankjank148

New Member
Joined
Jun 6, 2021
Messages
10
Location
Virginia
Thanks for the ad. Looking for a little help. I recently purchased a 2103 Wrangler Sahara. The Jeep had an issue with the shifter (automatic) when I bought it. At some point something broke or wore out, the small access hole to the right of the shifter was open and previous owner told me that a small green lever needed to be pushed down to take it out of park. This does release it, but I want to repair the issue I have replaced the brake lite switch, whole shifter mechanism, and still nothing. The dash states “vehicle not in park” and all the drive gear letters are surrounded with a square box (pic attached). I have power down to the shifter when I step on the brake pedal, the small solenoid (blue in color) under the
Shifter works when I put 12volts to
It and pushes
The green lever down to release the locking mechanism. I’m totally lost !!!! Reverse lights don’t work, and it says “vehicle not in park” on the dash. Any help would be appreciated!!!

5B41AB31-955D-4916-A6C9-BFF73B5A954A.jpeg
 

JerryD

¯\_(ツ)_/¯
Supporting Member
Joined
Dec 20, 2019
Messages
690
Location
West Michigan
Since you can apply 12 volts and start it, the solenoid sounds good. Any other electrical symptoms? As simple as this may sound, it sounds like a blown fuse. Since you've done some pretty good troubleshooting already I would check the fuse box next.
 
OP
F

Frankjank148

New Member
Joined
Jun 6, 2021
Messages
10
Location
Virginia
Thanks for the response. I have already checked the TIPM and every fuse/relay is good. I’m leaning towards the TCM or the Relay INSIDE the transmission. With these symptoms I have wrote, I figured someone out here has had the same problem. (Vehicle not in park) displayed on dash, all gears surrounded by the squares, shifter stuck in park, etc
 

MacGuyver

JK Enthusiast
Supporting Member
Joined
May 13, 2020
Messages
882
Location
Wisconsin
Take some pics of the thing you are suppose to push to take it out of park.

Does it tell you when your doors are open? Does the radio turn off only after you open the door? Does it happen the same for all the doors? This message can be activated when a door is not closed. It could be that somebody tried to disable the door sensor.
 
OP
F

Frankjank148

New Member
Joined
Jun 6, 2021
Messages
10
Location
Virginia
Yes it says when doors are open. I checked all the doors and they are fine. I’m not asking for anyone to search you tube for a solution, I’m hoping someone had the same issues that I’ve already described. There are no other issues. The green lever is the over ride lever invade the battery dies. So it can be put in neutral to tow or move it. I would think that with all the gears being lit up and the words on the dash, that may be a clue to someone who had the same issue. Appreciate your help.
 
OP
F

Frankjank148

New Member
Joined
Jun 6, 2021
Messages
10
Location
Virginia
I’m leaning towards the “neutral safety switch/gear selector indicator which is inside the transmission. I’m hopeful that someone had one that puked and had the same symptoms
I’m having.
 

TwiztedJezter

New Member
Joined
Jun 10, 2021
Messages
7
Location
Georgia
I'm having the same issue. I checked every fuse related to the transmission or the brake interlock. My issue happened a little differently. I was stopped at a red light and pulled away once it turned green. Everything operated fine for half a mile or so and then the light on the dash displayed it was in neutral even though the selector was in drive. I pulled over and shifted it to park and the selector became locked in park. If it is not raining again today when I get home I plan to crawl under the vehicle and inspect the shifter cable and bushings.
 
Last edited:

TwiztedJezter

New Member
Joined
Jun 10, 2021
Messages
7
Location
Georgia
Will do. I've seen a million of these posts and no one ever posts how the issue was resolved. You have a 2013 model and I have a 2018 model so there may be slight differences but I would think the system functions in the same way for both models.
 
  • Like
Reactions: Barry

TwiztedJezter

New Member
Joined
Jun 10, 2021
Messages
7
Location
Georgia
I thinks it more of an electrical issue also but upon scouring Google it seems this is a common issue with all Jeep products as well as the Dodge Challengers. Some have found broken springs inside the shift selector that has caused the issue so I'm wondering if it could be something internally in the shift selector that isn't easily viewable with just the console cover removed.
 

TwiztedJezter

New Member
Joined
Jun 10, 2021
Messages
7
Location
Georgia
Oh yeah its definitely an electrical issue then. I dont know if the neutral safety switch or the valve body would be a possible cause for your problem too.
 
OP
F

Frankjank148

New Member
Joined
Jun 6, 2021
Messages
10
Location
Virginia
Ok. Just learned the Jeep does NOT have a sensor in the transmission we are calling the “neutral safety switch”. There is a plate called the electrical connector plate. This plate has a built in sensor/s and also houses the solenoids. I’m searching now for symptoms of a failed or failing electrical connector plate. Finger crossed !
 

TwiztedJezter

New Member
Joined
Jun 10, 2021
Messages
7
Location
Georgia
Thanks for the info. I just ran across a video on YouTube of someone replacing it and calling it a neutral safety switch. Keep us updated. I also linked to the YouTube video I ran across.
.
 
  • Like
Reactions: Budjiman

TwiztedJezter

New Member
Joined
Jun 10, 2021
Messages
7
Location
Georgia
Just a quick update. I got home this afternoon and it's still spitting rain so I jumped in the jeep and started it and viola...everything works. I believe it's gonna be one of the intermittent gremlins that I'm facing. I do have a check engine light now and I'm gonna run the scanner and see what codes it produces.
 
  • Like
Reactions: mrjp

TwiztedJezter

New Member
Joined
Jun 10, 2021
Messages
7
Location
Georgia
Just finished up with the scan tool and I had 2 codes stored. U0404(Implausible Data received from ESM) and U0103(Lost Communication with Electric Gear Shift Module)
 
  • Like
Reactions: mrjp

Anubiscon

New Member
Joined
Jan 21, 2023
Messages
1
Location
Webster, FL
Any permanent solutions found? Dealing with the stuck in park "intermittent gremlin"... john
I've been dealing with the same issue for over a year. 2012 jeep wrangler rubicon unlimited. I can go into drive reverse the only gear it reads is neutral. But every other gear is "Park" there's 1 permanent low voltage code. I've replaced the battery 4 times. I was also told to replace the app sensor. I bought a new gas pedal which didn't fix the problem. Nobody in florida seems to know what the problem is.
 

Robert1976

New Member
Joined
Feb 1, 2023
Messages
2
Location
Deltona fl
I’ve got same problem on 2014 wrangler, dealer replaced shift mod, and tipm, gave back to me not working, now they want to do transmission computer; they can’t find out just keep charging me
 
  • Face Palm
Reactions: mrjp